安云网 - AnYun.ORG | 专注于网络信息收集、网络数据分享、网络安全研究、网络各种猎奇八卦。
当前位置: 安云网 > 业界资讯 > 极客品尝 > 在iPhone4S上安装Nmap以及Metasploit

在iPhone4S上安装Nmap以及Metasploit

时间:2014-12-31来源: 作者:点击:
4s越狱了很久,没怎么太装游戏,那就装点东西进去试试能不能渗透吧,嘿嘿嘿。首先需要的是越狱,5.01的越狱早已经出来了,越狱过程就不多说了,越狱完之后,打开cydia,安装openssh,安装

-------------------------------

在iPhone4S上安装Nmap以及Metasploit

//内容来自安云网



//内容来自安云网

4s越狱了很久,没怎么太装游戏,那就装点东西进去试试能不能渗透吧,嘿嘿嘿。首先需要的是越狱,5.01的越狱早已经出来了,越狱过程就不多说了,越狱完之后,打开cydia,安装openssh,安装Sbssettings,安装APT 0.6 Traditional,如果想要在手机上直接命令行,还要安装MobileTerMinal。

//内容来自安云网


//内容来自AnYun.ORG

在iPhone4S上安装Nmap以及Metasploit

//内容来自AnYun.ORG


//内容来自安云网

在iPhone4S上安装Nmap以及Metasploit //内容来自安云网


//本文来自安云网

装好了这两样东西以后,我们可以进入安装toggle ssh,方便控制ssh的启动和结束,把ssh的开关打开,在无线局域网里面查看一下手机的IP地址,然后从pc机上用putty或者是SecureCRT去连手机的ssh,默认的用户名密码为: //本文来自安云网

user:root
password:alpine //内容来自AnYun.ORG 

如果无法连接,可能需要重启下手机,看rp吧,反正我是一次就成功了。ssh上去以后,首先改下root的密码吧,输入 //内容来自安云网

passwd //内容来自安云网 

然后根据提示输入自己的密码:

//内容来自AnYun.ORG


//本文来自安云网

在iPhone4S上安装Nmap以及Metasploit //内容来自安云网


//内容来自安云网

在iPhone4S上安装Nmap以及Metasploit //内容来自安云网


//内容来自安云网

然后我们可以使用apt-get了,先装环境和必要工具吧,顺便把nmap一起装上 //内容来自AnYun.ORG

apt-get install adv-cmds apt basic-cmds bootstrap-cmds bzip2 class-dump coreutils developer-cmds diskdev-cmds file-cmds gawk gdb git gzip iokittools less make nano network-cmds ldid openssh rsync shell-cmds system-cmds com.ericasadun.utilities top uikittools findutils inetutils diffutils lsof subversion vim xar tar patch unrar unzip wget whois xml2 zip p7zip nmap python 

//内容来自AnYun.ORG

在iPhone4S上安装Nmap以及Metasploit

//内容来自AnYun.ORG


//本文来自安云网

在iPhone4S上安装Nmap以及Metasploit //内容来自AnYun.ORG


//内容来自安云网

下面进入安装metasploit的目录: //内容来自安云网


//内容来自安云网

cd /private/var //内容来自AnYun.ORG 

下载安装ruby环境,不要使用最新的,cydia提示也别更新,否则metasploit将无法运行,使用下面的命令来下载并且安装。

//内容来自AnYun.ORG


//内容来自安云网

wget  
tar jxpf framework-4.0.0.tar.bz2
apt-get remove ruby rubygems
wget http://apt.saurik.com/dists/tangelo-0.9/main/binary-iphoneos-arm/debs/ruby_1.8.6-p111-5_iphoneos-arm.deb
dpkg -i ruby_1.8.6-p111-5_iphoneos-arm.deb
wget http://apt.saurik.com/dists/tangelo-0.9/main/binary-iphoneos-arm/debs/rubygems_1.2.0-3_iphoneos-arm.deb
dpkg -i rubygems_1.2.0-3_iphoneos-arm.deb 
//内容来自安云网

到此,Metasploit应该就能运行了,我们安装的是metasploit的4.0版本,删除下载的安装包 //本文来自安云网


//内容来自安云网

rm ruby*
rm fr* 

//本文来自安云网

来试试运行

//内容来自AnYun.ORG


//本文来自安云网

cd msf3
./msfconsole 
//内容来自安云网


//内容来自AnYun.ORG

成功!效果在第一张图,很多教程里面说使用svn update去更新一下metasploit,就我实验结果来看,更新以后metasploit将无法运行,就算把ruby升级到最新也木有用呀,会报错,所以大家还是不要update先。

//本文来自安云网

有问题欢迎大家留言讨论! //内容来自安云网

顶一下
(0)
0%
踩一下
(0)
0%
------分隔线----------------------------
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
评价:
验证码: 点击我更换图片
相关内容
推荐内容